Follow

Why do I receive an error, transaction index required?

The error transaction index required would indicate that the transaction index from the 3D Secure Lookup was not passed through to the Authorise and Settle leg of the transaction.

Due to the fact that your Merchant Account is loaded as a 3 D Secure Merchant Account, you are required to do the 3 D Secure Lookup and Authenticate.

If this has not been done, please see below link: https://developer.mygateglobal.com/integration-guides/3d-secure-introduction

If this has been done and the 3 D Secure Transaction index have been received, please insure that this is sent in the Transaction Index field of the Authorise and Settle.

For Examples on the full process ie: 3 D Secure and Authorise and Settle, please click on the below link:
https://developer.mygateglobal.com/sample-code-downloads/my-enterprise-with-3d-secure-downloads

Was this article helpful?
0 out of 0 found this helpful
Have more questions? Submit a request

0 Comments

Article is closed for comments.